.NET 4.6 Installation Error When Installing Microsoft Dynamics GP 2016 R2 Prerequisites

March 28th, 2017 by

Microsoft Dynamics GPOne of the prerequisites of Microsoft Dynamics GP 2016 R2 is .NET 4.6. However, occasionally when installing it, the Microsoft Dynamics GP 2016 Bootstrapper Setup will throw an error showing that the .NET Framework installation failed:

.NET installation error

Microsoft Dynamics GP 2016 Bootstrapper Setup

An error occurred while installing system components for Microsoft Dynamics GP 2016 Bootstrapper. Setup cannot continue until all system components have been installed.

The problem is that neither this error message nor the error log it directs you to contains information as to the cause of the error.

However, all is not lost. If you use Windows Explorer and navigate to the folder, expand the DotNetFX460 folder, you can run .NET 4.6 installer (NDP46-KB3045557-x86-x64-AllOS-ENU.exe) manually and, running it this way, the installation error message is displayed:

Microsoft .NET 2015 installer

Microsoft .NET 2015

Setup has detected that this computer does not meet the requirements to complete this operation. The following blocking issues must be resolved before you can proceed.

Blocking Issues:

The update corresponding to KB2919355 needs to be installed before you can install this product on Windows 8.1 or Windows Server 2012 R2.

Armed with the KB number (2919355) you can download the update. Once installed, you’ll be able to progress with the installation of Microsoft Dynamics GP 2016 R2.

Read original post .NET 4.6 Installation Error When Installing Microsoft Dynamics GP 2016 R2 Prerequisites at azurecurve|Ramblings of a Dynamics GP Consultant

Source: azurecurve

Leave a Reply